Do you have questions about performance or outages? Our friendly Customer Care team can help! Get in touch
We have taken measures to address the issue affecting European services, and service availability has improved.
Microsoft Azure continues to report an active regional degradation. We are monitoring the platform closely while recovery is verified.
Monitoring
We have taken measures to address the issue affecting European services, and service availability has improved.
Microsoft Azure continues to report an active regional degradation. We are monitoring the platform closely while recovery is verified.
Identified
The issue is worsening and our European services are currently unavailable for many customers.
We have identified an ongoing issue with Microsoft Azure affecting the platform and are monitoring the situation closely.
Investigating
We are investigating an issue with Microsoft Azure affecting parts of our European services. Some customers may experience intermittent errors or slow loading when using Common Features.
We are monitoring the situation closely and will provide further updates as more information becomes available.