Do you have questions about performance or outages? Our friendly Customer Care team can help! Get in touch
We have taken measures to address the degraded performance and the issue affecting Search on the European system. Performance levels have improved and Search functionality has been restored.
We will continue to monitor the system closely to ensure everything remains stable.
Monitoring
We have taken measures to address the degraded performance and the issue affecting Search on the European system. Performance levels have improved and Search functionality has been restored.
We will continue to monitor the system closely to ensure everything remains stable.
Identified
Performance levels on the European system have returned to normal. However, we have identified that the Search function is currently not working as expected.
Our teams are investigating this issue and working on a resolution.
Investigating
We have received reports that some customers on the European system are experiencing severely degraded performance when using the Staffbase web application.
You can see on which system your application is hosted by going to Studio > Settings > API Access.
We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support team at support@staffbase.com.