Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Attachement uploads on Internet Explorer not working
Incident Report for Staffbase
Resolved
Our developers implemented a fix for this behavior on Internet Explorer.

Attachments, as well as media files, should now be able to be uploaded again as intended

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Jun 26, 2020 - 12:32 CEST
Investigating
We are currently experiencing an issue with attachment uploads on Internet Explorer. Our developers are currently looking into this topic with a high priority.

Workaround: Attachment uploads should be working as intended on every other up-to-date browser. If you can use alternative browsers such as Chrome or Firefox in the meantime, you should be able to use this feature without any issues.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Jun 25, 2020 - 14:17 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Common Features).