Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Native App - Plugins (forms, calendar, event registration, etc.) aren't working
Incident Report for Staffbase
Postmortem

Now that our investigation of the incident is complete, we are in a position to provide you with more detailed information about what occurred.

Summary

Between October 9, 12:30 PM and 15:45 PM (CEST) certain users reported issues with various plugins, including the calendar plugin, forms plugin, custom plugins and the launchpad. These plugins displayed error messages and failed to load successfully. The issue affected both iOS and Android devices, but not the web version.

What happened

An update was released, which was intended to implement improvements, but unfortunately resulted in a previously undetected issue that prevented the plugins from functioning as intended.

Impact

Users attempting to open a plugin from the menu encountered an unresponsive menu item. An attempt to open a plugin from a different location resulted in the generation of an error message that effectively prevented further access to the plugins.

Future improvements

We will implement additional testing procedures to ensure we are able to flag such a wrong behaviour internally before a public release.

Posted Oct 10, 2024 - 16:46 CEST

Resolved
We have released an update to resolve the issue and all functions of the app have been restored.
We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Oct 09, 2024 - 15:45 CEST
Identified
We have identified the root cause of the issue and will now take steps to fix it.
Posted Oct 09, 2024 - 15:22 CEST
Investigating
The Launchpad and several plugins, including forms and the calendar plugin, are currently not working in the native app.

Some users will experience that opening plugins in the native app is currently not possible.

Our teams are investigating the issue and working to resolve it as soon as possible. We will provide more information soon.

You can see which system your app is hosted on by going to Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions about this issue, please contact our support team at support@staffbase.com.
Posted Oct 09, 2024 - 15:12 CEST
This incident affected: Employee App & Front Door Intranet (Native App - iOS, Native App - Android).