Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Global] [App/Intranet] – Video Upload Not Working

Incident Report for Staffbase

Resolved

The video upload issues for some specific videos affecting all systems have been resolved. All systems are now operating normally.
We apologize for any inconvenience this may have caused.
If you are still experiencing issues, please reach out to our support team at support@staffbase.com.
Posted Jun 03, 2026 - 16:52 CEST

Investigating

Affected feature: Video Upload

We have received reports that some customers are currently unable to upload videos to the platform, even when the files meet our technical requirements.
Our teams are actively investigating the issue. We will provide a further update as soon as we have more information. We apologize for the inconvenience.
If you have any questions, please reach out to our support team at support@staffbase.com.
Posted Jun 03, 2026 - 15:49 CEST
This incident affected: App, Intranet & Staffbase Email (Media API (Americas) [SLA], Media API (Europe) [SLA], Media API (Asia/Pacific) [SLA]).