Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet/Email] [US System] - Degraded performance in App/Intranet & Employee Email

Incident Report for Staffbase

Monitoring

We have taken measures to address the degraded performance on the US system, and performance levels are back to normal. Users should now experience normal loading times in the App/Intranet and Employee Email.

We will continue to monitor the system closely to ensure performance remains stable.

If you continue to experience slow or unresponsive behavior, please contact our support at support@staffbase.com
We’re happy to help.
Posted Feb 19, 2026 - 20:05 CET

Investigating

Affected feature: App/Intranet & Employee Email

We have received reports that some customers on the US system are experiencing very slow or unresponsive behavior in the App/Intranet and Staffbase Employee Email. Our teams are investigating the behavior and will work to resolve this as quickly as possible. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com
Posted Feb 19, 2026 - 16:42 CET
This incident affects: App, Intranet & Staffbase Email (Core API (Americas) [SLA], Web Application (Americas) [SLA], Staffbase Email API (Americas)).