Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] [German System / US System] - Analytics for recently sent out Emails not shown

Incident Report for Staffbase

Resolved

The issue is resolved and analytics are shown again for the affected mails. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Jan 16, 2026 - 22:20 CET

Identified

We have identified the root cause for analytics not being shown for emails send out in the last 6 hours (starting 3:00 PM CET) and will now take steps to fix the issue. No data is lost and the analytics for the affected mails will be available again after this incident is resolved.
Posted Jan 16, 2026 - 20:58 CET
This incident affected: App, Intranet & Staffbase Email (Staffbase Email Tracking Service).