Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Contacting Support - Issues with contacting our support team via email
Incident Report for Staffbase
Resolved
We were able to resolve the issue and are receiving all emails to our support address again.

Unfortunately, we were not able to recover emails that were not received during that time. If you did not get an automated confirmation message with a ticket number from us, please re-send your message to support@staffbase.com or at https://support.staffbase.com/hc/requests/new, so that our support team can get back to you as soon as possible.

We are sorry for the inconvenience this has caused.
Posted Apr 09, 2024 - 17:32 CEST
Monitoring
We have noticed a positive improvement in the receipt of emails and will continue to work on a full resolution of the issue.
Posted Apr 09, 2024 - 15:43 CEST
Identified
Affected feature: Writing emails to support@staffbase.com

Our teams have identified issues with ticket creation at our support address. If you have reached out to support@staffbase.com via email and you haven't received an automatic confirmation, the ticket has not been created yet.

In the meantime, you can create tickets via our support portal: https://support.staffbase.com/hc/requests/new

We apologize for the inconvenience and will update you on the progress.
Posted Apr 09, 2024 - 11:42 CEST
This incident affected: Staffbase Support.