Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Issues with sending push notifications on prod/de and prod/us
Incident Report for Staffbase
Postmortem

As our investigation of the incident is complete, we would like to provide you with more detailed information about the push notification outage and loss that occurred on February 15 from 8:14am CET until 11am CET.

Summary of the issue:
In the observed timeframe, our push notification system experienced a misconfiguration, resulting in push notifications not being sent out properly.

What happened:
Our developer team identified and rectified the misconfiguration. At 11 am, the issue was corrected, and the push notification system was fully restored. Unsent push notifications had to be retriggered again.

Impact:
During the affected time window, no push notifications were sent. Our developer team identified and rectified the misconfiguration and at 11 am, the issue was corrected, which fully restored the push notification system. Unsent push notifications had to be retriggered again.

Future improvements:
To prevent similar incidents resulting from misconfigurations, we are enhancing our pre-release tests for the push notification system. This will include more rigorous checks to ensure the correct configuration of the system before any updates are deployed.
Thank you for your patience and understanding while we worked to resolve this issue. We recognize the importance of reliable push notifications in your daily operations and are committed to continuously improving our services to meet your expectations.

If you have any further questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com

Posted Feb 23, 2024 - 13:47 CET

Resolved
The issue is resolved. We apologize for the inconvenience this has caused.
Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Feb 15, 2024 - 15:44 CET
Monitoring
We have rolled out an update to fix the issue. New push notifications should be delivered as usual. All push notifications that were sent between 8:12 and 11:00 will not be delivered, they need to be resent.

We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Feb 15, 2024 - 11:09 CET
Investigating
Affected feature: Push Notifications

Some customers may experience difficulties receiving push notifications.
Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Feb 15, 2024 - 10:36 CET