Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption: connection issues for the web application

Incident Report for Staffbase

Resolved

This incident has been resolved.

The update has been successfully implemented and we have received positive feedback from our provider, that no unexpected amount of requests has been monitored. Therefore automatic IP blocking as caused by the initial update on May 27th will not happen again.

If there are any questions left regarding this incident, please reach out to our support team at support@staffbase.com and we are happy to help you.
Posted Jun 19, 2020 - 14:07 CEST

Monitoring

A fix has been implemented. We are currently monitoring this topic and will update you soon.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Jun 18, 2020 - 13:46 CEST

Identified

We can probably normalize the availability of the app for you in the near future. In the course of our cause-study, we have found that a recently installed update has led to a peak in the number of requests to our provider. The provider then interpreted these frequent requests as DDOS attacks (i.e. a significantly too high number of requests that could potentially overload the provider's platform) and automatically blocked the corresponding IP addresses.

If you are experiencing ongoing reachability issues on a certain location, please get in touch with support@staffbase.com and send us the IP address of your network/VPN, for which the app is not available, to unblock it as soon as possible. Please let us know if we can assist you in finding the correct IP, we will be happy to contact you by phone.

This is a temporary workaround to normalize the behavior for you and to restore the accessibility completely, a permanent solution will be evaluated by our developers and then implemented

We would like to apologize for the inconvenience and will, of course, in the aftermath of this case, investigate how we can avoid similar cases in the future.
Posted May 28, 2020 - 10:46 CEST

Update

We are continuing to investigate this issue.
Posted May 27, 2020 - 15:53 CEST

Investigating

We are currently experiencing a service disruption for our web applications. Your app might be periodically slow or unresponsive and your browser might show up a “Connection Reset” error.

Our team is working to identify the root cause together with our hosting provider. We will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted May 27, 2020 - 11:53 CEST