Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption with the German media server
Incident Report for Staffbase
Resolved
The issue has been resolved.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Nov 26, 2020 - 11:30 UTC
Investigating
We are currently experiencing a service disruption with the German media server. Your media uploads (pictures, videos, attachments) might be periodically slow or unresponsive.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Nov 26, 2020 - 09:17 UTC
This incident affected: Infrastructure (Germany) (Media API (Germany)).