Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German & US datacenter
Incident Report for Staffbase
Resolved
The issue has been resolved and your app should be completely reachable again. We apologize for the inconvenience.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Feb 12, 2020 - 17:14 CET
Monitoring
Our US system should be completely reachable again and the German datacenter will be back in a few minutes. Your application might still load longer than usual at this moment.

We will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Feb 12, 2020 - 17:04 CET
Identified
We are currently experiencing a feature disruption in the German and US datacenter. Your application might be unreachable or might load slowly. We expect the services being back in the next minutes.

We will post additional updates as soon as possible.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Feb 12, 2020 - 16:53 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (US) [SLA], Core API (Germany) [SLA]).