Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email Modern] [US System/German System] - Entra Unable Sync Contacts

Incident Report for Staffbase

Identified

We have identified the cause of the synchronization failures, our teams are currently working on applying the necessary configuration fixes to restore normal synchronization behavior. We will provide another update as soon as more information is available.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Apr 24, 2026 - 20:57 CEST

Investigating

Affected feature: Entra Contact Syncing

Some customers may be experiencing a delay in sending test emails on Email Modern. We have not noticed this to be an issue affecting all customers, only some.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Apr 24, 2026 - 19:03 CEST
This incident affects: App, Intranet & Staffbase Email (Common Features).