Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Longer Loading Times
Incident Report for Staffbase
Resolved
Our provider has implemented a fix and the performance of the app is back to normal. We consider this issue resolved.
We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Nov 23, 2021 - 13:47 CET
Identified
Our teams are currently investigating increased loading times and connectivity errors in the app. We have identified an issue with one of our providers and are working closely with them to find a quick solution.

We apologize for the interruption. In case you have any questions about this topic, please let us know at support@staffbase.com.
Posted Nov 23, 2021 - 11:17 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (Germany) [SLA]).