Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Mission Control
Incident Report for Staffbase
Resolved
The fix for the beta feature is fully implemented and the analytics for newly assigned campaigns and posts added to campaigns are displayed again. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Jul 09, 2024 - 14:19 CEST
Monitoring
Some customers might experience missing analytics for newly assigned campaigns or posts added to campaigns caused by an error in the current calculation for campaign metrics.
We have identified the root cause and are in the process of rolling out the fix. Once this is live, all the updated numbers will be available.
We will post an update once the fix is fully implemented.
Posted Jul 08, 2024 - 18:19 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Common Features).