Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - Delay in Email Delivery
Incident Report for Staffbase
Resolved
Throttling has subsided within SES, and emails should be sending as normal. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems.
Posted Nov 25, 2024 - 19:06 CET
Investigating
Some Customers may be experiencing a roughly 10 minute delay for email sending at this time due to throttling within Amazon's SES.

The issue should resolve itself shortly as Amazon's queue is lowered.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Nov 25, 2024 - 17:39 CET
This incident affected: Employee Email (Web Application (US) [SLA]).