Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Communications Control] Newly created content can't be saved
Incident Report for Staffbase
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Dec 31, 2024 - 13:39 CET
Identified
We have identified the root cause and will now take steps to fix the issue in the next hours.
Posted Dec 31, 2024 - 09:20 CET
Investigating
Communications Control customers may be experiencing trouble when trying to save new content of any kind.
Our teams are investigating and will work to resolve this as fast as we can.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Dec 30, 2024 - 10:49 CET
This incident affected: Communications Control (former dirico platform) (Communications Control Web Application [SLA]).