Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Email - Web App is experiencing long loading times
Incident Report for Staffbase
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Oct 10, 2024 - 00:58 CEST
Monitoring
We have taken steps to resolve the issue with the Staffbase Email Web App, and are seeing improved performance. Users should be able to log in and use the member site as normal. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Oct 09, 2024 - 22:49 CEST
Identified
We have identified the root cause of the Staffbase Email Web App's degraded performance, and are taking steps in order to resolve the issue at this moment in time
Posted Oct 09, 2024 - 21:47 CEST
Investigating
Affected feature: Staffbase Email

Some users may be experiencing longer than normal load times for various areas of the Web App, including Drafts and Sent Emails

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Oct 09, 2024 - 20:21 CEST
This incident affected: Employee Email (Web Application (US) [SLA]).