Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] Email Designer unable to save and load drafts

Incident Report for Staffbase

Resolved

The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Nov 22, 2023 - 16:23 CET

Investigating

We are currently experiencing an issue with the Email Designer in the DE Staffbase Email instance. Customers are currently unable to save drafts due to this error.
Posted Nov 22, 2023 - 07:14 CET
This incident affected: Employee Email (Classic) (Web Application (Germany) [SLA]).