Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - [US - Unable to load drafts]
Incident Report for Staffbase
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 21:08 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2023 - 23:28 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 18, 2023 - 22:56 CEST
Investigating
Affected feature: Unable to load drafts

Users may be experiencing an issue with loading drafts on the email designer.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 18, 2023 - 21:22 CEST
This incident affected: Employee Email (all regions) (Client Integrations (US) [SLA]).