Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German datacenter
Incident Report for Staffbase
Resolved
Referring to our last message about the performance of your app, we are now sending you the promised update.

On Monday, 25 November 2019, at 8.30 a.m. (CET), our developers noticed enormous load peaks on our German system, which resulted in longer loading times and poor availability of your app.

Until about 13.00 (CET), we were able to eliminate several capacity bottlenecks and thus achieve a full resolution of the issue. Subsequently, our development team has been monitoring the app performance extensively and can now confirm a normalization of the situation.

We apologize for the inconvenience. If you have any questions, please contact our support team at support@staffbase.com or call +49 371 91909090.
Posted Nov 27, 2019 - 14:29 CET
Monitoring
The cause has been identified and we have implemented a solution. The performance should be back to normal by now. We are monitoring the implementation of the solution to quickly react on potential issues.

Please report any unusual behavior to support@staffbase.com and we will be happy to help you.
Posted Nov 25, 2019 - 14:03 CET
Update
We have identified one potential root cause and are continuing to investigate the issue.

We will post additional updates as soon as possible.
Posted Nov 25, 2019 - 10:14 CET
Investigating
We are currently experiencing a service disruption in the German datacenter. Your app might be periodically slow or unresponsive.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted Nov 25, 2019 - 08:44 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (Germany) [SLA]).