Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Unavailability for App & Intranet on the German system
Incident Report for Staffbase
Postmortem

Now that our investigation of the incident is complete, we would like to share more detailed information on what happened.

Summary:
We experienced an unusually high load of user searches that used a large part of the available CPU and, therefore, slowed down our systems.

Impact:
Due to slower API requests some applications on our German system were not reachable for up to 1 hour.

Future Improvements:
We have identified the following future improvement to prevent similar incidents from occurring:

  • Adjust the timeout for long running searches to stop those earlier and retain the necessary CPU for operating all customer apps.
  • Adjust the monitoring of all search queries to take necessary steps before customer apps are affected.

We thank you for your patience and understanding as we work to improve our systems and prevent future incidents. If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Apr 03, 2023 - 09:37 CEST

Resolved
Some customers may have experienced problems loading/opening the app on March 15th.

The behavior started at 8:46pm CET and was caused by an internal connection error leading to a performance drop. At 9:41pm CET the performance issues were fixed, and all customers should be able to load/open the app again.

We apologize for the inconvenience.
If you are still experiencing the behavior or if you have a question about it, please contact our support team at support@staffbase.com.
Posted Mar 15, 2023 - 20:30 CET