Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet/Email] [German System / US System / Pacific System] - Scheduled posts are visible to end users

Incident Report for Staffbase

Postmortem

Summary

As our investigation of the incident is now complete, we would like to share more details about the issue that occurred between June 17, 05:00 PM CEST, and June 18, 10:56 AM CEST.

What happened

A recent update altered the functionality of scheduled posts, resulting in unpublished but scheduled posts being visible to end users when they accessed the news page.

Impact

During the specified timeframe, end users had access to news posts that were intended to be scheduled for future visibility and, as such, should not have been accessible at that time.

Future Improvements

We are implementing measures to enhance our overall test coverage, with the goal of avoiding similar incidents in the future.

Please contact us at support@staffbase.com if you have any further questions regarding this topic or if any feature is still impacted against our expectations.

Posted Jun 23, 2025 - 11:19 CEST

Resolved

We have implemented an update to resolve the issue, so that scheduled posts are no longer visible to end users.

We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jun 18, 2025 - 10:56 CEST

Identified

We have identified the cause of the issue and are currently in the process of implementing a solution.
Posted Jun 18, 2025 - 10:35 CEST

Investigating

Affected feature: News posts

Some customers might observe that scheduled posts are visible to users on the news page, even though they haven't been published yet.

Our teams are currently looking into this matter and will work to resolve it as quickly as possible. We will provide further updates shortly.

We apologize for any inconvenience this may cause. Should you have any inquiries regarding this matter, please feel free to contact our support at support@staffbase.com.
Posted Jun 18, 2025 - 10:19 CEST
This incident affected: App, Intranet & Staffbase Email (Common Features).