Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Plugins in Internet Explorer
Incident Report for Staffbase
Resolved
The issue has been resolved and the fix has been rolled out to all applications. We’ve successfully monitored the affected issues and can confirm that the App and all Plugins will now also work again as intended on Internet Explorer.
We apologize for the inconvenience.

If you have any questions, please contact our support team at support@staffbase.com and we will be happy to help you.
Posted Jul 07, 2020 - 10:04 CEST
Investigating
We are currently investigating an issue with our non-core plugins, not loading in Internet Explorer. Our developers are working on this with high priority.

We want to apologize for the inconvenience. If you have any questions regarding this incident please reach out to our support team: support@staffbase.com
Posted Jul 03, 2020 - 15:46 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (US) [SLA], Media API (US) [SLA], Core API (Germany) [SLA], Media API (Germany) [SLA], Common Features, Native App - iOS, Native App - Android).