Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Technical difficulties with the US server
Incident Report for Staffbase
Postmortem

On Saturday, February 10, 2024, at 12:10 AM UTC, a service disruption occurred, affecting the American instances of our Staffbase Employee App.

Our Infrastructure team detected a Distributed Denial of Service (DDoS) attack (targeted overloading of the system by a large number of requests) taking place on the American servers. The team conducted a comprehensive investigation into the extent of this attack and successfully restored the service on the same day at 3:15 AM UTC.
The effect of the incident is inaccessibility or overload of the American servers and the respective applications hosted within. This also affected individual functions, such as push and e-mail notifications, plug-ins and media.

The confidentiality and integrity of personal data, as well as internal information of your Staffbase account, were not affected at any time. The attack is a pure overload of the system and only the availability of the data was impacted.

We have initiated the development of a comprehensive system, known as “Staffbase Protect” designed to proactively counteract incidents of this kind in the future. More detailed information on Staffbase Protect and its implementation will be communicated to all app/intranet customers in the next weeks.

We thank you for your patience and understanding as we continue to improve our systems and prevent future incidents. If you have any questions or concerns, please contact our support team at support@staffbase.com.

Posted Feb 13, 2024 - 17:58 CET

Resolved
We have closely monitored our systems and haven't observed the same behavior again. Therefore, we are pleased to inform you that the incident has been resolved.
We sincerely apologize for any inconvenience this may have caused you.
If you are still encountering any difficulties, please feel free to contact us at support@staffbase.com. We are here to assist you.
Posted Feb 12, 2024 - 09:28 CET
Monitoring
The issue has been identified and mitigated by our teams. All our services have been restored. We will continue monitoring the stability of the solution.
Posted Feb 10, 2024 - 03:47 CET
Investigating
Our US server is currently experiencing technical difficulties, and as a result, some services might temporarily be unavailable. Our developers are currently working on a fix.

We appreciate your patience and understanding and apologize for any inconvenience. If you have any questions about this topic, please let us know at support@staffbase.com.
Posted Feb 10, 2024 - 00:47 CET
This incident affected: Employee App & Front Door Intranet (US) (Core API (US) [SLA], Media API (US) [SLA], SCIM API (US), Web Application (US) [SLA], Videos in Rich Content (US), Postman (US), Mail Services (US), Push Notifications (US)).