Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [DE System] – Delays in email processing

Incident Report for Staffbase

Resolved

We've received confirmation from our provider that the incident impacting email processing has been resolved. Should you encounter any further issues with email delivery, please do not hesitate to contact us. We are happy to help.
Posted Oct 01, 2025 - 08:44 CEST

Identified

We are currently aware of an issue with our external email provider that is impacting email processing. As a result, some users may experience delays in receiving emails.

Our provider is actively investigating and working to resolve the problem. We are monitoring the situation closely and will provide updates as more information becomes available.

You can follow the provider’s own updates here: https://status.mailjet.com/incidents/fntld4k6fdd3

Thank you for your patience while this is being addressed.
If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 30, 2025 - 14:18 CEST
This incident affected: Staffbase Support.