Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Campaigns section in the Analytics tab loading incorrectly for US / EU systems

Incident Report for Staffbase

Resolved

The issue has been resolved. We apologize for the inconvenience this has caused.
Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Mar 26, 2025 - 09:23 CET

Monitoring

Teams have identified the root cause and have taken steps to resolve the misconfiguration, we are monitoring the situation to ensure stability
Posted Mar 25, 2025 - 20:19 CET

Update

This is also impacting the EU system, teams are investigating further

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Mar 25, 2025 - 18:21 CET

Investigating

Customers in the US system may be seeing a loading issue with the Campaign section of the Analytics tab.

We will provide updates as soon as we have more information.

We apologize for the interruption. In case you have any questions about this topic, please let us know at support@staffbase.com.
Posted Mar 25, 2025 - 17:52 CET
This incident affected: App, Intranet & Staffbase Email (Web Application (Americas) [SLA]) and Staffbase Support.