Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System / US System] - Issues retrieving data via the user API

Incident Report for Staffbase

Postmortem

Summary

As our investigation of the incident is now complete, we would like to share more details about the issue that occurred between May 5th, 13:40 CEST, and May 6th 20:08 CEST.

What happened

A backend modification intended to enhance the performance of the /api/users endpoint inadvertently altered its behavior.

Impact

During the specified time period, user API requests containing high offset values failed and returned “400 Bad Request” errors due to the search limit of 100,000 records.

Future Improvements

We have increased the maximum results window to ensure that requests with high offset values are properly handled by the API. In addition, we will introduce improved operational checks and optimize the warning mechanisms to prevent future incidents due to possible misconfigurations.

Please contact us at support@staffbase.com if you have any further questions regarding this topic or if any feature is still impacted against our expectations.

Posted Jun 10, 2025 - 11:35 CEST

Resolved

Affected feature: User API

Between Monday, May 5th, 13:40 CEST, and Tuesday, May 6th, 20:08 CEST some customers may have experienced difficulties in retrieving user data through the User API. Requests to the User API may have returned an incorrect number of users or resulted in a "400 Bad request" error.

Our development team addressed the issue as soon as they became aware of it.

We apologize for the inconvenience. If you have any questions regarding this matter, please contact our support team at support@staffbase.com.
Posted May 05, 2025 - 14:00 CEST