The issue regarding News post creation and image loading has been resolved. All systems are operating normally.
We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Apr 23, 2026 - 17:35 CEST
Identified
We have identified the root cause of the issues affecting News post creation and image loading. Our teams are now working to implement a fix to restore full functionality. We will provide a further update as soon as more information is available.
Posted Apr 23, 2026 - 15:46 CEST
Investigating
Affected feature: News & Media
We have received reports that some customers are experiencing issues when creating News posts. Additionally, we are aware that images may not load correctly for some users.
Our teams are investigating the behavior and will work to resolve this as fast as we can. We will share more information soon.
We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Apr 23, 2026 - 15:29 CEST
This incident affected: App, Intranet & Staffbase Email (Media API (Americas) [SLA], Common Features).