Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Partial service disruption: media servers
Incident Report for Staffbase
Resolved
Hereby we’re announcing the disruption with our media server has now been solved. The incident of blurry or missing image uploads should not occur anymore. All the images which have been on your app will be automatically fixed so you don't need to do anything.

We apologize for the inconvenience.

Feel free to reach out to us via support@staffbase.com if you need any assistance or help.
Posted Jul 26, 2019 - 09:24 CEST
Identified
We are currently experiencing a service disruption with our media servers. You might notice that some images are not loaded properly.

The cause has been identified and we are working on a solution.
Posted Jul 24, 2019 - 18:04 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Media API (US) [SLA], Media API (Germany) [SLA]).