Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2024 - 11:00 CEST
Update
Correction: The migration will take place on 9 October 2024. We apologize for the incorrect information in the original post.
Posted Sep 26, 2024 - 17:29 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 26, 2024 - 16:59 CEST
Scheduled
To continue offering you a stable and future-ready service, on Wednesday, October 9th around 11 a.m. (CEST) we will perform a scheduled transfer of our primary domain staffbase.com to a different registrar.
The migration will take a maximum of 2 hours to complete. There is no action required of you as a customer.
We do not expect any complete service interruption. Any platform instability should not last longer than a few minutes.
If you have any questions, please reach out to our support at support@staffbase.com.
Posted Oct 09, 2024 - 11:00 CEST
This scheduled maintenance affected: Employee Email (Web Application (US) [SLA]) and Employee App & Front Door Intranet (Core API Protect (US) [SLA]).