Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Desktop menu background is not properly displayed
Incident Report for Staffbase
Resolved
The issue has been solved and all the apps should display the menu properly. We apologize for the inconvenience.

Feel free to reach out to us via support@staffbase.com if you need any assistance or help.
Posted Aug 12, 2019 - 09:34 CEST
Identified
We are currently experiencing an issue which partially cuts off the menu background on the desktop version of the app.

We identified the cause and our developers are preparing a fix at the moment. It will go live in the next 24 hours.

We apologize for the inconvenience.
Feel free to reach out to us via support@staffbase.com if you need any assistance or help.
Posted Aug 08, 2019 - 10:22 CEST