Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Email - Log in issues on the German system
Incident Report for Staffbase
Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted May 14, 2024 - 19:38 CEST
Monitoring
We are seeing improvements in the stability for Email customers on the German server and believe customers should be able to log in again. We will continue to monitor the situation to ensure everything is in working order.
Posted May 14, 2024 - 18:55 CEST
Investigating
Affected feature: Log in on Email for customers on the German server

Some users may be experiencing issues with logging in to the email product.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted May 14, 2024 - 18:17 CEST
This incident affected: Employee Email (all regions) (Web Application (Germany) [SLA]).