Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Studio is not responsive
Incident Report for Staffbase
Postmortem

Summary
As our investigation of the incident is complete, we would like to provide you with more detailed information about the incident that occurred on July 8, 2024, between 5:00 CET and 5:40 CET.

What happened:
We implemented a mechanism to check if all activated features for a customer app are applicable, which was not as performant as we anticipated from our tests. This caused the general performance to degrade, causing requests getting queued or not being processed. Our developer team could identify the root cause quickly and rolled out a fix right away, which restored the general performance. 

Impact:
During the incident period, users experienced delays in system responsiveness, with some unable to access the apps on momentarily.

Future Improvements:
We know how important it is for you that the platform is accessible at all times. Ensuring reliable performance is, therefore, our highest priority. We will focus on improving our internal review processes and do our best to avoid such incidents in the future.

For further inquiries or assistance, please feel free to contact us at support@staffbase.com.

Posted Aug 12, 2024 - 18:06 CEST

Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Jul 08, 2024 - 17:39 CEST
Identified
Administrators may notice that the Staffbase Studio is currently not responsive or taking longer times to load.
We have identified the root cause and will now take steps to fix the issue.
Posted Jul 08, 2024 - 17:27 CEST
This incident affected: Employee App & Front Door Intranet (Common Features).