Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Degraded performance on our international server
Incident Report for Staffbase
Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jun 28, 2024 - 13:19 CEST
Monitoring
We are pleased to inform you that our teams have made substantial progress in enhancing the performance of the server. As a result, we anticipate that customers should now be able to use their apps without encountering issues. We will continue to closely monitor the situation to ensure sustained improvements and will provide you with further updates as soon as possible.
Posted Jun 27, 2024 - 16:01 CEST
Investigating
Affected feature: Core API

Some customers may experience extended loading times. Our teams are actively investigating this issue and are committed to resolving it promptly. More details will be shared shortly.

To identify the system where your application is hosted, you can navigate to Studio > Settings > API Access and verify the tag displayed next to the title.

We apologize for any inconvenience this may have caused. If you have any inquiries regarding this matter, please don't hesitate to contact our support team at support@staffbase.com.
Posted Jun 27, 2024 - 14:07 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Core API Protect (US) [SLA]).