Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [Global] - AI Navigator doesn't show results and returns to process' starting point

Incident Report for Staffbase

Resolved

This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Jul 07, 2026 - 14:52 CEST

Monitoring

Update: We have deployed a fix for the issue that prevented users from starting new conversations in the Navigator AI Assistant. Functionality has been restored, and we are now monitoring all environments to confirm.

Impact was limited to starting new conversations in the AI Assistant. Other platform features were not affected.
We will post a final update once monitoring confirms full stability.
Posted Jul 06, 2026 - 17:13 CEST

Investigating

Affected feature: AI Navigator

We have received reports that some customers are experiencing issues with AI Navigator, where new requests do not load results and instead return to the start of the request.

Our teams are investigating and will work to resolve this as quickly as possible. We will share more information soon. You can see on which system your application is hosted by going to Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support team at support@staffbase.com.
Posted Jul 06, 2026 - 15:57 CEST
This incident affected: App/Intranet/Email (Web App (Americas) [SLA], Web App (Europe) [SLA], Native App - iOS, Native App - Android).