Service disruption: Forms not working on Internet Explorer 11
Incident Report for Staffbase
Resolved
The issue has been resolved and our Forms are working on Internet Explorer 11 again.
We apologize for the inconvenience.
Posted 5 months ago. Sep 11, 2018 - 16:02 UTC
Investigating
We are currently experiencing a service disruption for our Forms Plugin, which might not work on Internet Explorer 11.

Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted 5 months ago. Sep 11, 2018 - 13:03 UTC
This incident affected: Common Services (Plugins, Push Notifications...) (Plugins).