Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[Email] - Saving and Loading Issues in the Email Designer
Incident Report for Staffbase
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Jan 18, 2024 - 16:55 CET
Investigating
Affected feature: Saving and Loading Issues in the Email Designer

Users may be experiencing issues saving and loading the Email Designer.

Our technical team is actively addressing the matter, and as a solution to improve performance, we have temporarily removed tooltips from the Email Editor’s toolbar. This adjustment aims to immediately enhance the responsiveness of our platform while our developers work on a permanent fix.

We apologize for the inconvenience. If you have any questions regarding this topic, please get in touch with our Support Team at support@staffbase.com.
Posted Nov 15, 2023 - 22:44 CET
This incident affected: Employee Email (all regions) (Web Application (US) [SLA], Web Application (Germany) [SLA]).