Welcome to Staffbase Status

We are continuously monitor outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption: Push & Mail Notifications
Incident Report for Staffbase
Resolved
The issue has been resolved - all notifications are now processing and will be sent out within the next minutes. It is possible that there might be a short delay with newer notifications, however, the feature is working again.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Dec 02, 2020 - 12:46 UTC
Investigating
We are currently experiencing a service disruption with the Push Notification and Mail Notification feature.

Our team is working to identify the root cause. We will post additional updates as soon as possible.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support via support@staffbase.com.
Posted Dec 02, 2020 - 12:35 UTC
This incident affected: Notification Services (Push Notifications).