Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption: Open Groups
Incident Report for Staffbase
Resolved
The issue has been resolved and the "Open Groups" feature is working again.

Some users might have lost their internal and/or their open groups. The internal groups can be re-added with your next user import.

Please feel free to reach out to us via support@staffbase.com if you need further guidance or have questions concerning this issue. We apologize for the inconvenience and thank you for your patience.
Posted Sep 27, 2018 - 18:34 CEST
Identified
We are currently experiencing a service disruption with our "Open Groups" feature. Users who are manually removing themselves from a Open Group might be also removed from internal and/or conditional groups. This could cause the menu to disappear.

Our team is working hard to identify the root cause. We will keep you posted!
Posted Sep 27, 2018 - 15:15 CEST