Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Slower performance for Employee App & Front Door Intranet on the German server
Incident Report for Staffbase
Postmortem

Summary of the Issue

We have completed our investigation of the incident and would like to provide you with detailed information regarding the incident that occured on November 12 between 11:30 AM and 12:53 PM. During this period, users may have encountered slow response times or failing requests when trying to access the platform.

What happend

The increase in requests on the German server resulted in a degradation in backend performance, resulting in slower response times due to the high load. The issue has been resolved by increasing the backend capacity.

Impact

All users who were active during the designated timeframe may have encountered delays in response times or unsuccessful requests.

Future Improvements

We will continue to closely monitor the backend performance and make any necessary adjustments to prevent similar incidents from occurring in the future.

Posted Nov 13, 2024 - 15:11 CET

Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Nov 13, 2024 - 14:35 CET
Monitoring
We are seeing an improvement in performance which is resulting in the Employee App and Front Door Intranet working without delays. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Nov 12, 2024 - 12:53 CET
Investigating
Affected feature: Employee App & Front Door Intranet

Some customers may be experiencing slower/degraded performance in their Employee App & Front Door Intranet hosted on the German server.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Nov 12, 2024 - 11:50 CET
This incident affected: Employee App & Front Door Intranet (Web Application (Germany) [SLA], Native App - iOS, Native App - Android).