Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Issues with Single Sign-On
Incident Report for Staffbase
Postmortem

Postmortem

Now that our investigation of the incident is complete, we would like to share more detailed information on what happened.

The summary from October, 14:

We experienced an issue where customers using SSO were unable to log in.

What happened:

 The issue was caused by a recent update. The updated version introduced changes that were not compatible with our user profile logic.

Impact:

Customers with SSO configured were unable to access their accounts during the incident.

Future Improvements:

The immediate issue was resolved by rolling back the update. To prevent similar incidents in the future, we will explore implementing additional testing strategies for major dependency updates.

Posted Nov 22, 2024 - 15:34 CET

Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Oct 14, 2024 - 10:40 CEST
Investigating
We are currently experiencing issues with our Single Sign-On (SSO) system that may prevent some users from logging in successfully.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Oct 14, 2024 - 09:47 CEST
This incident affected: Employee App & Front Door Intranet (Common Features).