Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] [German System] - longer loading times

Incident Report for Staffbase

Postmortem

Summary

Now that our investigation of the incident is complete, we would like to share more details about the issue that occurred between February 12, 10:45 CET and 12:00 CET.

What happened

A configuration setting that did not fully account for how memory is utilized during high-traffic periods caused our system to slow down. This alarmed our teams, who immediately worked on increasing system capacity and restoring the performance of our system.

Impact

During the mentioned timeframe, users on our German system experienced long loading times and unresponsiveness when accessing the app or intranet. This was particularly noticeable when using the search functionality, which may have failed to return results or timed out.

Future Improvements

We will explore options to introduce additional testing setups and more granular monitoring to prevent similar issues in the future. We have also permanently increased the performance of our storage infrastructure. Please contact us at support@staffbase.com if you have any further questions or feedback regarding this topic.

Posted Feb 18, 2026 - 17:47 CET

Resolved

This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Feb 12, 2026 - 17:42 CET

Monitoring

We have implemented changes to resolve the issue and see performance going back to normal. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Feb 12, 2026 - 11:37 CET

Investigating

Customers may be experiencing slower performance and longer loading times on our german system.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Feb 12, 2026 - 11:10 CET
This incident affected: App, Intranet & Staffbase Email (Core API (Europe) [SLA]).