Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet/Email] [German System / US System] - news unread notifications in menu not updated

Incident Report for Staffbase

Monitoring

Update: We have deployed a fix for the issue that prevented unread notifications to properly update. Functionality has been restored, and we are now monitoring all environments to confirm.

We will post a final update once monitoring confirms full stability.
Posted Jul 08, 2026 - 14:13 CEST

Investigating

Affected feature: Menu Notifications

Some users may experience an issue where the unread notification count does not update correctly in the notification menu.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Jul 08, 2026 - 12:18 CEST
This incident affects: App/Intranet/Email (Web App (Americas) [SLA], Web App (Europe) [SLA], Native App - iOS, Native App - Android).