Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption in the German datacenter
Incident Report for Staffbase
Resolved
The issue has been resolved. We apologize for the inconvenience.
Posted Sep 04, 2018 - 10:08 CEST
Monitoring
A solution has been implemented.
Posted Sep 03, 2018 - 14:23 CEST
Identified
We are currently experiencing a service disruption in the German datacenter. Your app might be periodically slow or unresponsive.

Our team is working to resolve the root cause. We will post additional updates as soon as possible.
Posted Sep 03, 2018 - 10:47 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (Germany) [SLA], Media API (Germany) [SLA]).