Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Knowledge Base & support@staffbase.com not available
Incident Report for Staffbase
Resolved
Our tools are online again and our team is back with the usual availability. Thank you for your patience.
Posted Sep 09, 2020 - 17:29 CEST
Identified
We are currently experiencing a service disruption with our support tool provider "Zendesk". At the moment, our ticketing system (support@staffbase.com) as well as our knowledge base (support.staffbase.com) are not reachable. Zendesk is already aware of this situation and is working on getting the tools ready again.

Our response times might be slower than usual, however, you can still call us in the meantime via +49 371 91909067.

We’ll update this entry as soon as the issue has been resolved.
Posted Sep 09, 2020 - 14:01 CEST