Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Email delivery issues in the German server
Incident Report for Staffbase
Resolved
This incident has been resolved.
All systems are fully operational.
Posted May 14, 2021 - 14:25 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
All email notifications should shortly arrive in your inboxes.
If you still face any issues, please reach out to us at support@staffbase.com
Posted May 14, 2021 - 12:13 CEST
Investigating
Our team is working to identify the root cause. We will post additional updates as soon as possible.
Posted May 14, 2021 - 11:56 CEST
This incident affected: Employee App & Front Door Intranet (Germany) (Postman (Germany), Mail Services (Germany)).