Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App/Intranet] - Technical difficulties with the US server
Incident Report for Staffbase
Postmortem

Summary:
As our investigation of the incident is complete, we would like to provide you with more detailed information about the incident that occurred on February 22, 2024, between 16:55 CET and 17:23 CET.

What happened:
The incident was primarily triggered by a faulty update accessing our database, resulting in a gradual deterioration in system responsiveness.

Impact:
During the incident period, users experienced delays in system responsiveness, with some unable to access the apps on the ProdUs platform momentarily.

Future Improvements:
Immediate measures were implemented to address the issue, including adjustments to our database accessors and updates to enhance system stability. Additionally, corrective actions were taken to prevent similar occurrences in the future.
To fortify our infrastructure against similar incidents, ongoing efforts are focused on optimizing backend elements, implementing necessary updates, and refining code efficiency. Continuous monitoring and proactive measures aim to ensure sustained system stability and minimize disruptions to user access.

For further inquiries or assistance, please feel free to contact us at support@staffbase.com.

Posted Mar 20, 2024 - 13:39 CET

Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Feb 22, 2024 - 17:23 CET
Investigating
Our US server is experiencing technical difficulties and as a result, some apps might have been slower than usual or temporarily unavailable.

Our teams are investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Feb 22, 2024 - 16:59 CET
This incident affected: Employee App & Front Door Intranet (all regions) (Core API (US) [SLA]).