Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

[App] - Forms cannot be submitted via the Native App for some customers
Incident Report for Staffbase
Resolved
This incident has been resolved. We are sorry for the trouble this has caused.

Please contact us at support@staffbase.com should you experience any further issues. We’re happy to help!
Posted Mar 09, 2023 - 09:42 CET
Monitoring
We have fixed the issue and it should be possible to submit forms in the native App again. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Mar 08, 2023 - 17:28 CET
Investigating
For some customers, it is currently not possible to submit forms in the Native app.

Our teams are investigating the issue and working to fix the behavior as soon as possible. We will announce more information soon.

We apologize for the inconvenience. If you have any questions about this issue, please contact our support team at support@staffbase.com.
Posted Mar 07, 2023 - 17:04 CET