Welcome to Staffbase Status

We continuously monitor outages, slowdowns, and other issues. Should there be any interruptions in service, we'll provide status updates here.

Service disruption: Longer loading times
Incident Report for Staffbase
Resolved
The issue is resolved. We apologize for the inconvenience this has caused. Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Nov 10, 2021 - 11:14 CET
Monitoring
Our team has stabilized the app's performance - connectivity and loading times should be back to normal. We will continue to monitor the systems.
We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Oct 04, 2021 - 20:09 CEST
Investigating
Our teams are currently investigating issues with longer loading times. We will keep you updated on the progress as we learn more.

We apologize for the interruption. In case you have any questions about this topic, please let us know at support@staffbase.com.
Posted Oct 04, 2021 - 12:09 CEST
Monitoring
Our team has stabilized the app's performance - connectivity and loading times should be back to normal. We will continue to monitor the systems.
We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 22, 2021 - 21:54 CEST
Investigating
Some customers may be experiencing longer loading times and issues with images in their app.

Our teams are already investigating and will work to resolve this as fast as we can. We will share more information soon.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 22, 2021 - 13:12 CEST
This incident affected: Employee App & Front Door Intranet (all regions) (Media API (Germany) [SLA]).